请选择 进入手机版 | 继续访问电脑版
论坛
登录 | 立即注册 设为首页收藏本站 切换到宽版
查看: 141|回复: 2

A9G Flight mode not reconnecting

[复制链接]

2

主题

4

帖子

26

积分

新手上路

Rank: 1

积分
26
发表于 2019-8-7 18:58:26 | 显示全部楼层 |阅读模式
I am trying to use the flightmode setting on the A9G board

the following works:  Network_SetFlightMode(true);

But when i set  Network_SetFlightMode(false); and then Network_StartAttach();
the device will not reconnect to the network.

How can i make it reconnect after i have i used the flight mode?

I am wanting to use the flight mode to see if this can save some power by shutting down the modem.

Also does PM_SleepMode disable the modem? or just reduce power consumption
回复

使用道具 举报

1

主题

16

帖子

415

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
415
发表于 2019-8-30 17:11:26 | 显示全部楼层
Your operation is just to reduce power consumption and reduce the frequency.
回复

使用道具 举报

2

主题

4

帖子

26

积分

新手上路

Rank: 1

积分
26
 楼主| 发表于 2019-8-30 17:20:31 | 显示全部楼层

Yes – but I want to turn off the GSM modem to save more power.

When I detach from the network the device cannot reconnect.

I have tried the use the following ion different examples to make it reconnect – but none of these have worked,

Network_SetFlightMode(false);

Network_Register((uint8_t[]){0,0,0,0,0,0}, NETWORK_REGISTER_MODE_MANUAL_AUTO);

Network_StartAttach();

I want to make the device as low power as possible until it is time to wake up again.

Does setting the device PM_SleepMode(true); turn off the modem? Or it just makes the device slower?
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|安信可论坛    

GMT+8, 2019-9-16 12:00 , Processed in 0.017986 second(s), 12 queries , Redis On.

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表